Thursday, December 12, 2013

Java Versions

Java has got to be the app that causes the most problems.


1)      The version of Java should match the version of the browser.

2)      Most labs are using 32 bit browsers. In my current lab image, the icon for IE in the taskbar is using the 32 bit version while the one in Start Menu\Programs is 64. Firefox is 32.

3)      64 bit Java is not supported by some third party apps. I think these are non browser based apps.

4)      For full compatibility, both versions can be installed.

 

So, if you are in doubt, deploy both versions. If you only want one, deploy 32 bit. 

Thursday, October 3, 2013

AutoIt won't compile

I've installed AutoIt V3 and am always able to compile the first time. But after that it fails with the following error, no matter what I do.

Compile: Error opening destination file

It looks like the solution is to copy all the source files to another folder. Not sure why this works.

Wednesday, October 2, 2013

Regional language settings for all users

I wonder if this works better that the one in User Configuration\Preferences\Control Panel\Regional Options. I'm conflicted as the format tab still shows a different language. The language bar is showing accurately.

http://blogs.technet.com/b/askperf/archive/2012/08/16/how-to-change-regional-settings-for-all-users-on-a-computer.aspx

Thursday, September 12, 2013

Fuzzy video on Wyse S10


The resolution needs to be fixed on all incoming S10s. The new monitors, Dell P23112H, do not work well with the Wyse clients.

Resolution: 1680x1050
Refresh: 75 HZ
Desktop Color: 32 Bit

Thursday, September 5, 2013

Sysprep fatal error

Here's one of those unusual errors I run into while trying to sysprep a machine.  Sysprep chugs along, "Processing generalize clean up phase plugins..." and then screeches to a halt. With no apparent error, as it is running in quiet mode.

The error is in the setuperr.log

http://sysadministration.wordpress.com/2013/03/15/sysprep-fatal-error-with-ie-10/

Wednesday, August 21, 2013

Shortcuts not creating in group policy

I ran across an error when creating shortcuts using group policy preferences. I don't recall what the text of the error was, but it couldn't create the shortcut on the desktop. I did a couple of things:

1) Set the action to replace rather than create.
2) Set the location to desktop, not All Users Desktop

Friday, July 19, 2013

Deploy task sequence disables administrator account

I tried to deploy a task sequence with joining a workgroup and specifying an administrator password and account enabled. The error I got while trying to logon was that the administrator account was disabled. I've tried it repeatedly with images known to have worked if the domain was joined. I've come to the conclusion that this is a bug. I got around it by going into safe mode and enabling the account. It's not a big deal, as my use for this TS was to deploy an image that was clean and I could use to build with.

Wednesday, July 10, 2013

SCCM 2012 - Failed to run task sequence

I had a computer that was working fine before, suddenly unable to load the task sequence. The error was "The task sequence failed to start with error 0X80070570". Same as MDT, need to blow away the _SMStasksequence folders or better yet, the entire hard drive.

http://www.edugeek.net/forums/enterprise-software/112858-sccm-2012-one-computer-will-not-start-task-sequence.html

Tuesday, May 28, 2013

PXE Boot Fails from Task Sequence Media - Failed to download pxe variable file

Symptom: WinPE will boot as far as preparing network connections… then suddenly black screen and reboot

Error in \Windows\temp\SMSTSlog\SMSts.log is : PXE Boot Fails from Task Sequence Media - Failed to download pxe variable file
 
http://social.technet.microsoft.com/Forums/en-US/configmanagerosd/thread/95e475e2-d1cc-4de7-8014-23e7f562bcaa

Do the following:

dism /mount-wim /wimfile:r:\remoteinstall\boot\x64\images\boot_ 1.wim  /index:1 /mountdir:c:\temp\img

Copy the SMS\data folder from the boot media to the SMS folder in the mounted image folder

dism /unmount-wim /mountdir:c:\temp\img /commit

 

Tuesday, March 19, 2013

Text file formats

One needs to be careful when copying code from the web.  File formats do matter. For example, if one is copying code for the Windows Task Scheduler, it is done in UTF-16. If a text editor without support is used, the file might display and save correctly, but not run.

Come to think of it, I've occasionally run across this in code I write from scratch. I might have copied a portion from another source and it's enough to cause problems with running it. The best thing to do is to type in the code from scratch. That way, any hidden or uninterpretable characters will not be present.

I'm talking mostly about Windows batch files, but it could easily happen with any type of text file.

Tuesday, March 12, 2013

Optiplex 980 BIOS update breaks BartPE

I updated an Optiplex 980 from A07 to A13.  It broke booting BartPE from both USB and PXE.  I know I should get with it and use WinPE (I do for other reasons) but Bart generally works well for us. The error from PXE was:

Windows NT has found only 511K of low memory. 512K of low memory is required to run Windows NT. You may need to upgrade your computer or run a configuration program provided by the manufacturer

The USB didn't boot at all. The solution was to boot from WinPE (I only have a 64 bit version) and use Ghost64.exe. Worked perfectly.

We are using MDT and moving to SCCM anyway, I just don't have WinPE built with Ghost on it.

Tuesday, March 5, 2013

Unable to update collection. Insufficent rights - SCCM 2012

We made an attempt to implement role based security.  It had the effect of not allowing objects to be added to an existing collection that the user had created. A new collection would be fine.The reason is that the limiting collection is All Systems and the new security model does not allow modify access to that.

Upon attempting to add a machine to the collection, I get Unable to update collection. Insufficent rights. The Add Resource option for the computer is not available either. So new limiting collections are required that we have access to.

http://social.technet.microsoft.com/Forums/en-US/configmanagergeneral/thread/82516509-b063-4e52-bfdc-ac182db27e4d/

Update (03/27/13)

I tried to "Import Computer Information" manually.  Using a name and MAC address.  I had no problems adding it to my specified collection, but it would not show up in the SCCM database. Actually it does, but I don't have permissions to see it.  This is due to the limiting collection, which was "All Systems", then "All Windows Workstations". That did not work either, as the entry has nothing to indicate that it is a Windows workstation.

Monday, March 4, 2013

Group policy causing problems

There is something funny going on with a few machines I have in the lab.

1)      Group policy for this particular OU runs inconsistently. If it is not running, need to toggle UAC on/off

a.      Seems to be missing 11-19 Windows updates.  Nothing on WSUS server but 19 pending on MS site? Could be patch Tuesday…

2)      UAC needs to be off in order to make changes to Program Files\UltraVNC.

3)      UltraVNC finally accepted CTRL-ALT-DEL, but only after group policy successfully applied

4)      Forcibly removing the print driver using printui /s /t2 did not make a difference

5)      Printing still broken, now calculates incorrect page counts for both Word and Powerpoint

So, after doing the required Windows updates, the page count was correct again. Not sure what happened, but guessing the Windows updates caused it. Note that by default, Windows thought the updates were current from WSUS, but they weren't according to the manual update to the Microsoft site.
More specifically, I am layering group policy, and it was the last policy that did not apply, even though it was not denied.
I am guessing either KB2685811 or KB2685813 caused it, as the others are unlikely.
So if group policy is not applying properly, do a manual Windows update.

Tuesday, February 5, 2013

Creating Bootable Media for SCCM 2012

Is a bit of a hassle.  I used the create task sequence media to build the media.  I ran into two problems:

Failed to create media (0x80070057) CreateTsMedia 2/5/2013 2:07:35 PM 2540 (0x09EC)

and

Format failed (0x8004242D) CreateTsMedia 2/5/2013 2:12:44 PM 2756 (0x0AC4)

The first resulted from having both a mapped network drive and a hidden drive without a drive letter assignment.

http://support.microsoft.com/default.aspx?scid=kb;EN-US;2471018

The second happened because I am trying to use a 64 GB USB key and ConfigMgr does not support that. Kind of ridiculous.

sel dis #
clean
cre par pri
sel par 1
active
shrink desired=32768 minimum=32768
format fs=ntfs quick
exit

the magic line is shrink desired=32768 minimum=32768, works now in windows 7 !


http://qa.social.technet.microsoft.com/Forums/en-SG/configmgrosd/thread/9e6bd1e6-3b6d-43e4-8a87-f9c3ecf8a93b

Monday, January 21, 2013

BIOs updates for Optiplex 9010

The most common way to find BIOS updates for Dell Optiplexes is to go to the Dell drivers and downloads site and enter the service tag.  I have both an All-In-One and desktop that I acquired last year.  According to the previously mentioned website, there are no BIOS updates. I chatted with a Dell tech and there are updates. Just not there.  For everyone's reference, here they are.

Optiplex 9010 Desktop


Optiplex 9010 AIO

http://www.dell.com/support/drivers/us/en/555/DriverDetails/Product/optiplex-9010-aio?driverId=HPHR1&osCode=W764&fileId=3098295975

Happy BIOS updating.